3 Replies Latest reply on Jan 28, 2016 5:02 AM by Carlos_A

    Does CircuitCo still exist?

    erico Community Member

      I've purchased two MinnowBoard Max boards.   The first one arrived dead.  I obtained an RMA and sent it back to CircuitCo.   They re-flashed the board and returned it to me, the whole process took a little over a week.    It appeared to work fine, initially,  then died again about a week later and would not boot again.   In the meantime, I purchased another one,it appeared others weren’t having significant issues with the board.

       

      Back in November, 2015, I started the RMA process, for the first MBM, with the help of John Hawley.  

      On 12/2/2015, I received an e-mail from CircuitCo, stating they had received my board and that they would begin diagnostics and keep me posted.  

      On 12/11/2015, I had not heard back from CircuitCo, so I sent an e-mail requesting a status update. 

      I received a response the same day, they apologized and said their RMA dept. was backlogged and I would receive an update on Monday 12/14/2015.  

      I never received that update and that was the last time I’ve heard from CircuitCo .  I sent e-mails to CircuitCo on 12/26/2015  and again 1/5/2015, no response.  

      I’ve called CircuitCo several times, but there is never an answer.

       

      At this point, I’m not sure what to do, I’m open for suggestions.

       

        • Re: Does CircuitCo still exist?
          Carlos_A Brown Belt

          Hello erico,

           

          Thank you for contacting the Intel Embedded Community.


          Please address this request by filling the form stated at the Contact Us web site mentioned as a reference.

           

          We hope that this information is useful to you.

           

          Best Regards,

          Carlos_A.

            • Re: Does CircuitCo still exist?
              erico Community Member

              Thank you for the reply.  I've done as you requested and filled out the form Contact Us, with the link you've provided.    However, I posted this because, CircuitCo is NOT responding to any of my correspondence and whenever I've called, there is no answer.  They have had my board for almost two months now.

               

              The board initially cost $150 +shipping.    I have had to pay for all shipping costs sending/receiving this board to/from CircuitCo. I have sunk close to $200 in a board, I've really never been able to use.

               

              Thank you.