6 Replies Latest reply on Jun 18, 2016 4:17 PM by DarkTiger

    Cannot set bootstrap signals for DDI2 port on Haswell-based design

    DarkTiger Green Belt

      Hello

       

      I have a problem with Haswell-based board (4850) COM Express CPU board bHL6 with 440-pin system connector from Kontron:

      http://www.kontron.com/products/boards-and-standard-form-factors/com-express/com-express-basic/come-bhl6.html

      Actually, I have a problem with Haswell-4850 CPU, as DDI pins attached to processor directly (data via decoupling caps, of course)

      The problem is: I cannot bootstrap with DDI2 port. Troubles are with bootstrap configuration only, because I can install and load Linux (CentOS) with COM port console redirection to terminal and then switch DDI2 display port on in /etc/X11/xorg.conf.d. DDI2 works properly after that.

      (sorry for screenshot, it was easer at that moment):

      I cannot see any info at all (include BIOS screen) on eDP 4K display (LQ156D1JX01B), connected to DDI2 port. However, I can see all this info on DisplayPort, connected to reference CarrierBoard Type6 to DDI2:

      http://www.kontron.com/products/boards-and-standard-form-factors/com-express/starterkits-and-evaluation-boards/come-ref.-carrier-t6.html

      This problem reproduces on our 3 same boards, so it’s not a hardware contact's issue. Backlight enable and DIM signals are independent (not from CPU), always on (100% PWM fill).

      “pci” command from UEFI shell gives same results on both my and CarrierBoard:

         Seg     Bus        Dev        Func

          00       00           02 00 ==> Display Controller - VGA/8514 controller

                   Vendor 8086 Device 0D26 Prog Interface 0

      Same from lspci under Linux:

      00:02.0 VGA compatible controller: Intel Corporation Crystal Well Integrated Graphics Controller (rev 08)

      Bootstrap settings are:

      HPD signal: directly from HPD display’s pin (2.8V instead of 3.3, but I also tried to disconnect HPD wire from display and connect manually to 3.3V directly – with same result). Pull-down resistor (100k) placed on CPU module

      DDI2_DDC_AUX_SEL – pulled down with 100k on module. Tried to pull it up in connection with Intel’s manual, but with same results

      As far as I know there are no any other bootstrap signals, than can switch DDI port off. I sure that I set DDI2 settings in BIOS in proper way, because I have DisplayPort on my working monitor, connected to DDI2 on reference CarrierBoard and it works properly.

      Is there any more “secret” bootstrapping signals for Haswell that could switch DDI2 off after power is on? DDI2 just does not work, without any diagnostic messages.

      Schematics for reference Carrier board is quite simple, I copied it, but had no success:

      Maybe there is some test program that I could run from LiveUSB with test display modes? Really, all I need is to intall Win10 on module, then I can write a script to enable DDI2 in Win10. But Win10 doesn't have text install mode, so I can't use console redirection there.

       

      WBR,

      Nikolay