14 Replies Latest reply on Jun 22, 2010 12:12 AM by McLion

    AtomZ530 / US15W performance playback Flash content

    McLion Brown Belt

      Hi

       

      I have an embedded board that uses a Z530 and US15W chipset.

      I use Windows Embedded Standard 2009 (XPe) as OS (booting from microSD) and found that playing back Adobe Flash content from within the browser (IE7) with even low resolutions are very choppy.

       

      I feel like this can't be normal, is it? Any suggestions?

      Thanks

      Franz

       

       

       

        • Re: AtomZ530 / US15W performance playback Flash content
          Kirk Brown Belt

          This is a known limitation of upoptimized video code running on Z530.  Adobe has been promising to release the Z530 optimized version of Flash for a while now.  Intel was involved in getting the optimized code to Adobe and now we are just waiting for it to make it into their main release.

           

          You might want to see if you can get the beta of the latest version 10 release from Adobe as that is rumored to have SOME of the optimizations enabled.

           

          We may just need to be a bit more patient- help is on the way from Adobe.

           

          Hope this helps.

            • Re: AtomZ530 / US15W performance playback Flash content
              Brown Belt

              Hi Mclion,

               

              By the way can anyone let me know the procedure to boot the XPe from SD slot in Atom Z5xx?

               

              Is any standard procedure is available for this? Is any BIOS changes required for this?

               

              Regards,

              Imman  

               

               

                • Re: AtomZ530 / US15W performance playback Flash content
                  McLion Brown Belt

                  @Kirk

                  I'll try the prerelease from the Adobe Labs. Hope it helps. I am currently very disappointed from the performance of this 1.6GHz CPU.

                  Thanks.

                   

                  @Imman

                  To boot from SD you usually get a driver package as Component (sld) from the board manufacturer, i.e. Kontron in my case.

                  Without details, this would be:

                  - SD Bus Class driver (from Microsoft) to support the Host Controller

                  - SFF Storage driver (from Microsoft, and Kontron in my case) to support SD drive.

                  Of course, the BIOS needs to support it as well. However, if the board comes with a slot, I would assume that it does that already.

                   

                  HTH
                  Franz

                   

                • Re: AtomZ530 / US15W performance playback Flash content
                  McLion Brown Belt

                  Seems not to be so easy. According to Adobe labs and forum:

                   

                  - Acceleration is for H.264 (only ?)

                  - In current rc2 is disabled for GMA500 because of bad drivers

                  - Currently only for Win7 -> not available for XP and therefore XPembedded

                   

                  snip fron release notes:

                  Hardware video decoding of H.264 content in Flash Player 10.1 is supported on Intel® 4 Series Chipset
                  family and the all New 2010 Intel® Core™ Processor Family with Intel® HD Graphics starting with the
                  graphics driver version 15.16.5.2021(8.15.10.2021) for 32/64-bit Windows Vista and Windows 7.
                  For the Atom/Intel® GMA 500 chipset, hardware decode is supported starting with the graphics driver
                  version 5.2.1.2020 (8.14.10.2020) for 32-bit Windows

                   

                  I downloaded the current rc2 of Flash 10.1.

                  So, what driver for XP shall I use to test anyhow? 

                   

                  Thanks

                  Franz