6 Replies Latest reply on Apr 18, 2011 7:38 AM by philippechevalier

    WPF Rendering problem

    Green Belt

      Hi,

       

      We're running a WPF application on an embedded platform with an Intel 945 GME chipset. With hardware accelerated rendering enabled we have an issue where when the application starts up parts of the window which can be obscured by other windows don't get redrawn properly and get left with stale visuals or black boxes. If we disable hardware accelerated rendering then the problem goes away so we're pretty confident it's a problem with the graphics drivers.

       

      We're currently running the 10.0 version of the IEGD driver so we tried upgrading to 10.3 but that doesn't seem to fix it. However installing Intel Graphics Media Accelerator Driver v 14.32.4.4926 for Windows XP does fix the problem. We can't really use that driver for our platform so does anyone know what it might be about that driver that makes it work? Has anyone else seen this kind of thing? Any suggestions of how to make the IEGD driver work?

       

      Thanks,

      Mark Daniel.

       

        • Re: WPF Rendering problem
          Kirk Brown Belt

          We do not have any currently known issues with IEGD and WPF on 945 type graphics of which I am aware. You may have found a previously unknown issue in the driver, OR it could be an interpretation issue of Microsoft "specs" for WPF because MS is sometimes very vague on how things are supposed to work.  We have found times where the spec even tell you to have something work the wrong way that their code actually expects.

           

          Do you have access to the Intel Premier Support system where you could report the issue and provide a sample code that reproduces the issue?

           

          THX

          • Re: WPF Rendering problem
            Green Belt

            Dear Mark,

             

            Have you been able to fix your problem? We are facing similar issues with the 945GSE chipset on a Windows CE 5 platform.

             

            Regards,

             

            Nick Machielse

              • Re: WPF Rendering problem
                Green Belt

                Hi Nick,

                 

                No I'm afraid we haven't found a solution, it's only a problem just after startup so we decided to ignore it. We're moving over to Windows Embedded Standard 7 for our release this autumn so we'll see if that makes any difference.

                 

                Sorry I couldn't be more help,

                Mark

              • Re: WPF Rendering problem
                Community Member

                Have you enabled the Framebuffer Overlay Blending in IEGD? I know by default it is disabled. I recall reading something about opening mutple windows and one of the windows turning black. I have attached the Intel doc.

                  • Re: WPF Rendering problem
                    Community Member

                    The overlay framebuffer blending is not available on Windows CE for both EMGD and IEGD driver. So this could not be the problem. Where can I get samples of WPF to test? We are enabling Windows Embedded Compact 7 and would like to see if this issue still happens.