1 Reply Latest reply on Nov 16, 2010 6:04 PM by Kirk

    Latest EMGD 1.5 and OpenGLES 1.1 on WINXP / US15W

    Green Belt

      We manage to install the latest EMGD (1.5 / october) on our test platform (Atom Z530/US15W) but we cannot run any OpenGLES 1.1 test program on it.


      We notice that OpenGLES libraries are present on the system in C:\Windows\System32 :




      The opengles tests programs ( from PowerVR SDK 1.1 or other third parties ) crash (SIGSEGV as reported by gdb) in libGLES_CM!eglGetProcAddress() ( AFAIK the US15W is a PowerVR SGX). Other programs crah in others functions of libGLES, as if the first call to any function of this lib will lead to a crash.


      The PowerVR SDK provides examples that can be run with OpenGLES emulation (PVRFrame) on this platform  through OpenGL emulation correctly at a decent framerate , so it should works with the native OpenGLES implementation.


      The same happens with the OpenGLES2.0 SDK.


      Is there any example that demonstrate the use of this lib, with sources and projects files, even just initialisation ?


      Are these libs useable on this platform ?


      Best regards.




        • Re: Latest EMGD 1.5 and OpenGLES 1.1 on WINXP / US15W
          Kirk Brown Belt

          OpenGL 1.4 and 2.0 should be supported on US15W on Windows XP.  Contact your field rep for access to the EMGD Technical Product Spec (TPS) available through CDI/IBL (if you have access).  You have checked the Spec Update (Errata) for known IEGD issues?


          You should be aware that we implement the OpenGL capability differently on Windows so the sample code you have may not work without recompiling to our libraries.


          We generally do not provide sample code but if you have an Intel Premier Support account, you could open an issue and provide any sample code you think should work.


          Hope this helps.