2 Replies Latest reply on Aug 23, 2012 10:48 AM by chuckhorkin

    USB CDC Using Intel 5 Series Chipset

    Community Member

      Hello,

       

      We have an embedded product that came out a few years ago that uses the USB CDC to communicate with an external PC running windows over a virtual serial port.  Until recently this worked fine, but we are finding that the device doesn't work with computers running windows with the Intel 5 series chipset.  Does anyone know what has changed or might be the culprit?  Any help would be much appreciated.


      Thanks.

        • Re: USB CDC Using Intel 5 Series Chipset
          Felix_M BlackBelt

          Hello

           

          Can you say how you isolated the problem to the chipset  ?   Also can you describe a little about "it doesn't work".   With that extra info I can try to find someone who can help you.  

           

          Thanks

           

          Felix

           

          J. Felix McNulty

          Community Moderator

          Intel® Embedded Community

          (Intel contractor)

            • Re: USB CDC Using Intel 5 Series Chipset
              Community Member

              The symptoms of 'not working' are as follows (and all symptoms seem to be able to occurr on a single problem computer):

              -Sometimes when the device is connected, Windows says "Device Not Recognized" (code 43).

              -Sometimes when the device is connected, windows does identify the device, but shortly thereafter it says it is not working because the device cannot start (code 10).

              -I have done some work with netmon and it seems that there may be 'bad config descriptors' on this problem machine.

               

              My hunch is that this chipset is more picky in some way than others, which causes this not to work.

               

              In terms of identifying the chipset....

              We connected our device to approximately 10 computers.  All of the computers that had problems with the device had Intel 5 series USB ... in the Device Manager.  None of the computers that worked had this chipset listed for USB.

               

              Also, I see that that status USBD_STATUS_CRC is returned when the bad config descriptors happens.  Is this a HW problem with the chipset, maybe?