8 Replies Latest reply on Sep 30, 2013 10:10 AM by Kirk

    Emgd 1.18: issue opengl 2.0 not recognized and ced ch7317

    Razak Green Belt

      Hi i was building iemgd1.18 but i have noticed two things:

      1)opengl icd module not recognized on windows 8 embedded. Driver works but opengl2.0 can't be played

      2)slecting ch7317 from sdvo page report warning bar: set display configuration  but there no display section

       

      How can i resolve? Sdvo is working but is strange warning

        • Re: Emgd 1.18: issue opengl 2.0 not recognized and ced ch7317
          Kirk Brown Belt

          Hello,

           

          1) EMGD 1.18 is an XP (including the embedded version) and Linux.  It is not designed at ALL for Win 8 and should not work at all (the driver is an XPDM driver, not a WDDM 1.2 as is needed for Win8).  If you got it running at all, it does not surprise me that OpenGL would not work.  There are no plans to officially support US15w or E6xx processors on Win 8.  You did not say what you are running.

           

          2) Typically VGA parts like the CH7317 need to be able to be told if the display will be anything other than a VGA (like a SCART, or component video) but the default is VGA.  We appear to have an issue with CED as the attribute which should set the display type seems to have been dropped.  I am checking if that is intentional or accidental.  If intentional, the warning should have also been removed.  If accidental, we will need to put the display type attribute back in to CED. If you are using a VGA, then you are OK as that is default.

           

          Hope this helps.

           


            • Re: Emgd 1.18: issue opengl 2.0 not recognized and ced ch7317
              Kirk Brown Belt

              The CH7317 does not require that attribute but the CH7022 does.  Seems that the CED developers got that wrning on the wrong part.  Just ignore the warning.  Sorry for any confusion.

                • Re: Emgd 1.18: issue opengl 2.0 not recognized and ced ch7317
                  Razak Green Belt

                  hi kirk; thank you for your answer!

                  I'm Using IEMGD1.18 for Windows 7 not XP (XPDM) on a US15 Platform with 2 partition one for Win8emb the other one with Windows 8.1 Pro Preview Edition.

                  It's running  good but system doesn't recognize Opengl 2.0 included in IEMGD package and load only MS Opengl1.1

                  http://4.bp.blogspot.com/-Bq9cfzJ7iiQ/UidGqdEBKfI/AAAAAAAAAWs/14X1_CLWp9U/s1600/test.png

                  Windows 8 requires WDDM1.2 and 8.1 WDDM1.3  for hardware certification (but anyway iemgd doesn't have any certification)

                  If i look to the registry is all Ok! basing to the MSDN description seems to be all setted:  http://msdn.microsoft.com/en-us/library/windows/hardware/ff568203(v=vs.85).aspx

                  http://1.bp.blogspot.com/-OAHdFvKHSCA/Uii0XYHTVjI/AAAAAAAAAW8/4mPQGBgJwkY/s1600/reg.png

                   

                  Any solution?

                    • Re: Emgd 1.18: issue opengl 2.0 not recognized and ced ch7317
                      Kirk Brown Belt

                      Hi,

                       

                      EMGD1.18 for US15W on Windows is an XPDM driver.  I've never thought to try it on Window 8 as from information from Microsoft is that XPDM had been removed from Win8 on. It will support a WDDM1,1 driver but native is WDDM1.2.

                       

                      If there somehow still is a XPDM interface in Win8, it cannot be relied on.  However if XPDM is supported then there is no reason the general driver would not work on it, it is just something we do not test because it is not POR.  You may have INSTALLED EMGD 1.18, but are you sure it actually is running, and that the OS is instead running on its replacement for the VGA/VESA driver that may support US15W?

                       

                      Let's say there is somehow still an XPDM interface in Win8, and somehow the EMGD 1.18 is running.  For OGL, my guess (and it only can be a guess) is that the way OpenGL interfaces to the operating system was changed between Win XP/7 to Win 8.  In Win 7, the OpenGL was supposed to still work even though we only provided it in XPDM. For a chipset as old as US15W, if the driver works then great, but if things do not work on non-POR situations, then it is just not going to work.  Sounds like OpenGL is definitely in the later category.

                       

                      Can you go back and try on XP or Win 7?  Win 8 is not in scope for US15W...

                        • Re: Emgd 1.18: issue opengl 2.0 not recognized and ced ch7317
                          Razak Green Belt

                          Sorry kirk but I'm using this driver: Download Center

                          is WDDM1.1

                          Iemgd.png

                          note. Win8.x not support XPDM

                          ::::::::::::::::::::

                          WDDM driver is working good but OpenGL is my problem. Seems to be a driver bug :\

                            • Re: Emgd 1.18: issue opengl 2.0 not recognized and ced ch7317
                              Kirk Brown Belt

                              I see the driver you are using now and it is indeed a Windows 7 WDDM 1.1 driver.  My suggestion would be to:

                               

                              1. Double check the application is not attempting to use unsupported OpenGL functions.  The list of supported and unsupported is in the User's Guide with the release.

                              2. Try a CLEAN install.  Sometimes you need to uninstall any existing graphics drivers on the system and do a reinstall of the driver.  Sometimes old and new collide and that might be happening here.

                              3. Try it on Windows 7 as it is designed to work.  Win8 is NOT on our Plan of Record for US15w.  If Microsoft changed the OpenGL interface between Win7 and Win 8 (as I suspect they did when they implemented WDDM 1.2) then the Win 7 OpenGL will not work on Windows 8 ever.  If the Windows 7 does not seem to support OpenGL either, then there is a bigger problem.  We validate OpenGL on Windows 7 so it it should be functional.

                               

                              Hope this helps.