2 Replies Latest reply on Mar 18, 2014 3:18 PM by watermirror

    The remote end hung up unexpectedly

    watermirror Community Member

      Hi.

      I am building galileo follow:

      http://www.malinov.com/Home/sergey-s-blog

      my host is ubuntu 12.094

       

      I have build it successfully once.

       

      but last night, i want to restart the whole process. when I  execute setup.sh, errros comming:

       

      watermirror@WM:~/galileo/meta-clanton_v1.0.0$ ./setup.sh

      Running: git init

      Initialized empty Git repository in /home/watermirror/galileo/meta-clanton_v1.0.0/poky/.git/

      Running: git remote add origin git://git.yoctoproject.org/poky

      Running: git fetch origin --depth=3 tags/dylan-9.0.2:tags/dylan-9.0.2

      fatal: The remote end hung up unexpectedly

      fatal: protocol error: bad pack header

      Traceback (most recent call last):

        File "setup/gitsetup.py", line 131, in <module>

          main()

        File "setup/gitsetup.py", line 117, in main

          run_command('git fetch origin --depth=%s %s' % (opts.depth, fetchspec))

        File "setup/gitsetup.py", line 65, in run_command

          subprocess.check_call(command, shell=True)

        File "/usr/lib/python2.7/subprocess.py", line 511, in check_call

          raise CalledProcessError(retcode, cmd)

      subprocess.CalledProcessError: Command 'git fetch origin --depth=3 tags/dylan-9.0.2:tags/dylan-9.0.2' returned non-zero exit status 128

       

      i have tried many ways to fix it ,but failed.

       

      please help me out.

        • Re: The remote end hung up unexpectedly
          LynnZ Brown Belt

          Hello! I've sent this to a few colleagues to see if they can assist you but in the meanwhile, check out Space: Makers | Intel Communities.

            • Re: The remote end hung up unexpectedly
              watermirror Community Member

              Hi, LynnZ.

              I think there's some problem with the server. I can execute setup.sh ,but when i run bitbake image-full, new problem came out:

              Log data follows:

              | DEBUG: Executing shell function do_kernel_configme

              | [INFO] doing kernel configme

              | [INFO] Configuring target/machine combo: "standard/clanton"

              | [INFO] collecting configs in ./meta/meta-series

              | mv: target `3.8.7' is not a directory

              | creation of pre-processed config data failed

              | config of "standard/clanton" failed

              | ERROR: Function failed: do_kernel_configme (see /home/watermirror/galileo/meta-clanton_v1.0.0/yocto_build/tmp/work/clanton-poky-linux-uclibc/linux-yocto-clanton/3.8-r0/temp/log.do_kernel_configme.30614 for further information)

              ERROR: Task 348 (/home/watermirror/galileo/meta-clanton_v1.0.0/meta-clanton-bsp/recipes-kernel/linux/linux-yocto-clanton_3.8.bb, do_kernel_configme) failed with exit code '1'

              NOTE: Tasks Summary: Attempted 2646 tasks of which 2612 didn't need to be rerun and 1 failed.

              Waiting for 0 running tasks to finish:

               

              Summary: 1 task failed:

                /home/watermirror/galileo/meta-clanton_v1.0.0/meta-clanton-bsp/recipes-kernel/linux/linux-yocto-clanton_3.8.bb, do_kernel_configme

              Summary: There was 1 ERROR message shown, returning a non-zero exit code.

               

               

               

              by the way,  the bsp file i used is :

              Board_Support_Package_Sources_for_Intel_Quark_v1.0.0.7z,

              download from Download Center

               

              not Board_Support_Package_Sources_for_Intel_Quark_v0.7.5.7z

               

              what could i do now?

               

              thanks.