2 Replies Latest reply on Oct 17, 2014 4:27 PM by gabriel.thomas

    [edison] uart 1 setup

    proficnc Community Member

      Hi all
          I am using an Intel Edison, on a very basic breakout board, fixed level shifters to the serial ports.  it is fitted with an FTDI chip which is isolated via level shifters.   this interface works....

       

          However, I cannot see anything on the second UART, nor can I send anything.....

       

          Assuming an as set-up straight after firmware has been flashed, what is the best way to enable the UART and to monitor input from an external device?

        • Re: [edison] uart 1 setup
          gabriel.thomas Brown Belt

          Hello proficnc

           

          Welcome to the Intel® Embedded Community

          We are working on this issue, we will reply with more information as soon as possible.

          Best Regards,

          Gabriel

          • Re: [edison] uart 1 setup
            gabriel.thomas Brown Belt

            Hi proficnc.

             

            Please try the following code.

             

             

            on the Edison:
            +++++++++++
            /* Disable runtime PM on debug console and UART1 */
            cd /sys/devices/pci0000:00/0000:00:04.2/power
            echo on > control
            cd /sys/devices/pci0000:00/0000:00:04.3/power
            echo on > control

            #enable UARTRX and UARTTX level shifters
            echo 248 > /sys/class/gpio/export
            echo 249 > /sys/class/gpio/export
            echo 214 > /sys/class/gpio/export

            echo low > /sys/class/gpio/gpio248/direction
            echo high > /sys/class/gpio/gpio249/direction
            echo low > /sys/class/gpio/gpio214/direction

            Now you will need the special cable (FTDI USB-UART TTL-232R-1V8-2MM)that you have mentioned to plug into J1B1 Header
            to the 01 (Rx,Tx)

            http://www.ftdichip.com/Products/Cables/USBTTLSerial.htm

            [on PC side] minicom –s

            And configure to use </dev/ttyUSB<something>
            115200

            [on EDISON side] microcom –s <speed>
            microcom -s 115200 /dev/ttyMFD2


            Please if you make any change to these instructions or if this works let us know and post a confirmation.

            Regards.


            Gabriel


            PD: Thanks to Rama for the feedback