0 Replies Latest reply on Oct 3, 2015 2:00 PM by GDownes

    Temporary loss of video display on Intel BayTrail SoC (E3800-series) Atom when logging off in Windows 7 or resuming from sleep

    GDownes Community Member

      I think I have stumbled across a strange issue on the BayTrail E3845 Atom processor where you temporarily lose video output during a Windows 7 logoff or resume from system sleep.

      Since the BayTrail processor does not natively support LVDS, an eDP to LVDS bridge chip is used to generate a single LVDS output interface to an 18-bit LCD panel.  There is no 2nd display connected to this system as the E3800 series Atom supports 2 video output channels.

       

      When you log off from Windows 7 repeatitly, switch user, or exit out from a remote desktop session, you temporarily lose output video.

      The output (recommended) resolution set is 1024x768@60Hz with a pixel clock of 65MHz.  When video is lost, the pixel clock changes to 54MHz and slowly drifts back to 65MHz when video is restored.

      There is an EDID attached which only specifies 1024x768@60Hz resolution and no others.

       

      I have seen two different results between Windows 7 and 8 using the same Intel HD Graphics driver.

       

      The Windows 7 and 8.1 specifics are:

      * OS installation is Windows 7 pro 64bit with SP1

      * BIOS set to LVDS output

      * Panel Auto detect: Auto (EDID will be read first)

      * Display resolution set to 1024x768@60Hz

       

      Intel specific graphics drivers tested:

      > win64_153332 (Intel HD Graphics Driver for Windows 7 and Windows 8 64Bit Rev. 15.33.32)

       

      Windows 7 shows the issue while Windows 8 does not.

      When you log off Windows or resume from a sleep state, you temporarily lose the video output where I can only describe it as watching the blue fireplace channel.

      It happens for anywhere between 1 - 10 minutes before the video output is restored.  I measured the pixel clock and watched it change.

       

      The simple steps are:
      • Boot into Windows
      • Start menu > Log off OR
      • Start menu > Sleep (and resume from sleep)

       

      The Intel HD Graphics control panel in each OS, the following differences are observed after a clean install:

       

      1. Windows 8 correctly identifies the correct and desired video settings, ie supporting only 1 resolution of 1024x768 @ 60Hz, 70Hz and 75Hz as specified in the EDID.

      2. Windows 7 incorrectly identifies the video settings by showing an additional resolution not specified in the EDID, ie 800x600.  The EDID information is read in by windows and bound to the display adapter when you look in device manager.

       

      When video is lost, you either wait, or manually lock the computer using Windows + L, then CTRL + ALT + DEL, then pressing Enter to force a system log in and the 1024x768 resolution is restored.

       

      I can only come to the conclusion that there is a problem with the Intel HD Graphics driver under Windows 7.